Renaming in geometry

Hi everyone,

Since we can break APIs for Hipparchus/Orekit incoming major releases, and in light of this discussion as well as to avoid ambiguities, I propose to rename getNorm as getNorm2 and introduce a wrapper to it called getMagnitude, as the word magnitude is a common alias for the Euclidean norm. I haven’t checked yet for possible conflits with packages other than geometry.
How does that sound?