Rename FieldElement#add() method?


I would again like to ask, if in a future Hipparchus release we can rename
the FieldElement#add(T) method or create a new interface which “FieldElement can inherit from”
which introduces a new method plus(T) so we can hide the existing add(T) method.

So in Java programs which use the FieldElement interface in their classes and are lists
(similar for collections) at the same time, we can implement the java.util.List interface which
unfortunately has the same method signature. See:

Is this possible in a future Hipparchus release?

It is technically possible but will break a tremendous amount of existing (and difficult) code.

I am therefore quite reluctant to this change, but would like to see what other Hipparchus users think.
If we go this way, we should also change ‘subtract’ to ‘minus’ and ‘multiply’ to ‘time’ for consistency.

It is unfortunate the add term is so generic.

1 Like