Questions in propulsion/maneuver


A couple of questions:

  • why in a few classes it’s getISP while in most it’s getIsp?
  • why is there getMassDerivatives in ThrustPropulsionModel whilst it always wrapps getFlowRate in practise?


No reason, we are just inconsistent.
At first, we used full caps for acronyms, but changed our minds as it is cumbersome to read in camelCase naming convention.
We did not change everything, so there are some remnants of old convention.