Question about example Track Corridor

Python example Track Corridor, there is an error at runtime, the error occurs on this line: propagator.propagate(start, start.shiftedBy(DURATION)).Can anyone help me!Thanks!
JavaError: <super: <class ‘JavaError’>, >
Java stacktrace:
java.lang.RuntimeException: AttributeError
at org.orekit.propagation.sampling.PythonOrekitFixedStepHandler.handleStep(Native Method)
at org.orekit.propagation.sampling.OrekitStepNormalizer.handleStep(
at org.orekit.propagation.sampling.StepHandlerMultiplexer.handleStep(
at org.orekit.propagation.analytical.AbstractAnalyticalPropagator.acceptStep(
at org.orekit.propagation.analytical.AbstractAnalyticalPropagator.propagate(


It is hard to troubleshoot based on this minimum of information, but to get started i recommend:

  • Clone the orekit-python-wrapper repo:
  • Open the repository in vscode and open it using the devcontainer that contains a pre-setup environment based on orekit v12.0
  • The notebook can be run and edited in vscode directly without additional settings, I can confirm it works in the dev container (based on python 3.11 and orekit v12.0)



Ok thanks. I’ll try again.

Hello, I use jupyter notebook, in the example Track Corridor I have the following problem. The rest of the examples are fine.

Hello, can you provide me with the version number of cartopy you are using?

The problem has been solved. Thank you!

1 Like

Hello - new here on the Orekit forum.

I am getting the very same error as newWL using a jupyter notebook - any chance you can share how the problem was solved?

I am using cartopy 0.22.0, python 3.10.13 and orekit 12.0.1. I do not have vscode installed - I could do this, but am quite new to this tool (and Java) so would likely not be able to debug very efficiently.

I guess I am wondering about this example in general. Is there documentation on this example elsewhere? For example the ANGULAR_OFFSET = 35 - is this in arcminutes or something representing say the 3dB beamwidth of a tracking antenna?

Fiinally I am trying the debug facility in jupyterlab to look at this - it doesn’t seem very compatible (ipykernel keeps restarting) - can you confirm that debugging this way is not recommended or doesn’t work?

Try using Orekit 12.0, hopefully it can help you.


You are right, the v12 version wasn’t committed in the update. I have now commited the updated version and verified that it works in the devcontainer that is part of the repo (if one uses vscode).