Python wrapper for 11.1.2 available on conda-forge


An updated version 11.1 is released and in some minutes available on conda-forge.

This includes all changes in (java) orekit 11.1.2 version plus:

Thank you @petrus.hyvonen !!! :slightly_smiling_face:

Thank you so much!

Thank you @petrus.hyvonen for keeping the pace :wink:
The Python wrapper has become so valuable, thanks again :clap:

I concur!
Thank you Petrus !

Hi, I’m trying to install orekit on linux, anyway, using the conda-forge, only version 10.3.1 is being installed. I didn’t manage to upgrade it nor to install directly the latest version. Do you have any ideas? Thank you.

Hi, hard to tell, 10.3.1 is quite old. Try to make a new conda environment so there isn’t any other dependencies. The conda-forge files are in place at Files :: for all platforms
Which version of Python are you using, note that version 2 and <3.7 is not automatically built anymore.

you can also make sure you are using the right channel by specifying it explicitly:

conda install -c conda-forge orekit

Thanks Petrus, finally I managed to install it by providing directly the file of the correct version available in the link you provided.
It’s strange, but even if I had just installed anaconda with python 3.9.7, by running conda install -c conda-forge orekit it was always giving me version 10.3.1.

Hi Marc,

I am facing the same problem that you had, getting always the version 10.3.1.
Probably because for some reason it is diverting to the “next repodata source”:

~$ conda install -c conda-forge orekit
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: done

Can you detail a bit more how you solved it? (I’m new to this conda stuff)

Thanks a lot in advance for any help.

Hi @aerojmb,
go to the link with the conda-forge files provided by Petrus.
Then copy the link of the specific version you want to install.
Finally, launch from terminal conda install <file url>, substituting the file url you copied.

If I’m not wrong this worked for me. Another way would be to download the file in your computer and write its path after conda install.


This is indeed strange. It is likely something with conda/conda-forge but made an issue to start with in the orekit python issue tracker.

Could I please ask you to post there some details about your installations, how did you install conda (miniconda/anaconda/…), which platform, which python etc?

Conda forge not installing latest version (#446) · Issues · Orekit Labs / Orekit Python Wrapper · GitLab

Hi @marc ,
Thanks for the help. That fixed it, but on top of that I also had to explicitly install openjdk (conda install -c conda-forge openjdk), since when I removed the version 10.3.1 it removed openjdk as well, and installing the file directly does not seem to automatically install the dependencies.

Hi @petrus.hyvonen
I just added there a comment with that info.

1 Like