Problems with compilation of Hipparchus 2.0

I tried to compile Hipparchus 2.0 (core) with Oracle JDK and got errors:
…hipparchus\analysis\function\ error: cannot find symbol
return x.signum();
symbol: method signum()
location: variable x of type DerivativeStructure

…hipparchus\analysis\function\ error: cannot find symbol
return x.signum();
location: variable x of type T
where T is type-variable:
T extends Derivative declared in method value
. . . . .
= = = = = = = = = = = = =
And yes, I can’t find signum() method in DerivativeStructure class, Derivative class and parent CalculusFieldElement class

Same compilation procedure with Hipparchus 1.8 is OK.

Hi @nicksakva
The Signum class has been removed from the library in june (see commit c81a6a59).
This was after discussion concerning issue 138.

Thank you!
Removing from compilation procedure solved the problem.
May be it is better to remove it from source code for hipparchus-core 2.0 also.

It has been removed from the source in june.
I have just checked the download pages and neither, nor hipparchus-2.0-src.tar.bz2 or the maven artifacts hipparchus-core-2.0-sources.jar contain this file.

I don’t understand why you have this in your source tree. Maybe you unzipped/untarred the new release source tree on an existing directory? If you do this, obsolete files are not removed.

Yes, it seems to be my mistake as mix of new version with existing directory.
Sorry! :frowning: And thank you again!
I’ll try to be more careful.