Orekit python wrapper on Mac M2

Hi all,

Just wondering if there’s been any updates on getting a MacOS (apple silicon) version of the python wrapper working. I don’t see a version in conda-forge and am wondering if it’s just not available on the new mac hardware or if i’m missing something along the way.


Hi Joe,

Unfortionately there is still no conda version of orekit, this is on my to-investigate-list but it seems from my initial tests quite complex and I don’t have a mac to test with so every iteration takes about 20 mins to build :slight_smile:

Some more on why this is complex is in the thread: Orekit Python Wrapper 11.3.2 released - #6 by petrus.hyvonen

What is doable as a fix meanwhile is to use the alternative wrapper based on jpype, it has been confirmed to work on mac platform: Files · master · Petrus Hyvönen / orekit_jpype · GitLab


I might have it working, but don’t have a M1/M2 Mac to test on. Could someone please test the package that is on conda-forge (shoudl be there in about 1 hour)?


Hi @petrus.hyvonen,

I am trying to install Orekit 11.3.2 but my micromamba only finds a Python 3.8 version. On the conda repo I see that there are arm64 builds for all versions, but only a 3.8 for 64. Is that the problem? The Mac is not super recent.


Hi @Serrof , yes that is correct, the osx build is still struggling for versions above python 3.8, was trying some stuff today but still not working, it is related to the build pipeline I think and it may build if you would run conda build directly on your machine. The 3.8 version is latest however.

Oddly the M1/M2 is cross compiled on a osx (x86) as there are no arm VM’s in the build infrastructure, and they seem to build.cannot yet verify that they are working as expected though but seems to import.

I see, well I’ve tried installing and running Orekit 11.3.2 on Python 3.8 and it works. Thank you @petrus.hyvonen! I would prefer the latest version of Python of course, but no pressure :wink: