Java: Compilation failed: internal java compiler error with javac on Intellij

Hi everyone,

I wanted to know if anyone using IntelliJ could compile Orekit using the javac compiler ?

On my end, i can compile it just fine until release 10.1 with the introduction of the DefaultDataContext which seem to be the cause of my compilation error in addition to a huge penalty in compilation time when using Eclipse compiler.

For now i must switch to the eclipse compiler but it is a bit of a bother to change that everytime my configuration is reset :sweat: .



I always use Eclipse mode, Javac doesn’t work. Intellij seems to randomly switch back to the latter, annoying indeed.


Ok i may have found something, it seems that we need to define the path to the Annotation processors in Build,Execution,Deployment → Compiler → Annotation processors.

However and by default, the IDE doesn’t find the path even though the pom indicates to look inside :


Hence i think we need to fix the pom but still have not found how. I have been trying several fix with
<annotationProcessors>but nothing worked so far.


I use IntelliJ. I didn’t know about choosing Eclipse mode, so I assume I’m using javac mode? Running individual tests from the editor works fine. Some things that help are:

  • Explicitly use a 1.8 JDK (which I’m sure you already do) in the project settings
  • Use maven to perform a “clean” and “compile”
  • Right-click on the “compiler” folder (which contains the DefaultDataContextPlugin) in the project outline and select “Mark directory as → Excluded”

Hi @markrutten,

I have followed your instructions but unfortunately still encounter the same error. Could you check on your side as well @Serrof ?

I’m using java 1.8.0_362.


For me the maven compile fails due to Hipparchus’ snapshot status.

Are you sure Mark that you’re not in Eclipse mode?


Strange, don’t you have a local snapshot of Hipparchus installed ?