I think it’d be nice to have a
getRotation method for
AttitudeProvider using only
StaticTransform, if feasible. With attitude override like in maneuvers, it would avoid using the
getAttitude which goes through several
+1 for this idea. Don’t know if we’ll get a big performance improvement but I think anything that can speed up the code is beneficial.
Don’t you think this will induce lots of code duplication?
There are quite a number of attitude providers and if all methods should be maintained in both versions, it may diverge. Having both the field and double version of getAttitude is already a nightmare.
I don’t think so. The interface AttitudeProvider could have a default implementation wrapping getRotation and
getAttitude. Then classes like
LofOffset would overwrite it. The computational gain with
Field should be substantial. Actually, with
Field, any operation you don’t perform is a win. I’ll create an issue and propose an MR, then you guys can tell me again