2234 Errors when doing a build (Windows)

We get 2234 errors when doing mvn package assembly:single on Orekit10.1 (using JAVA SDK 14).

I have attached sure-fire error logs. I thought this was just meant to work when building? Also, the fact we can’t build using the Eclipse IDE is annoying.

Anyone have any ideas on why these unit tests are failing?surefire-reports.zip (1.1 MB)

I found the problem, doing a project clean in eclipse appears to have removed some of the files that were required by the unit tests. Taking a fresh download of Orekit10XX and trying to build that resolved the above issue.

After solving the above issue, we now have another issue:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.2-beta-5:assembly (default-cli) on project orekit: Error reading assemblies: No assembly descriptors found. -> [Help 1]

This is expected. Building using the assembly plugin has been removed on December 10, 2019. We forgot to update the documentation at this point, and fixed this on February 20, 2020. The instructions telling to use assembly:single that were present up to February 20 are obsolete. You should simply use mvn package, not mvn package assembly:single anymore.

Tried doing that, still getting similar errors as before. Maybe I’m doing something wrong?

error2

The error messages says it all: JAVA_HOME should point to a JDK not a JRE.

The difference between a JDK and a JRE is that the former is a complete development environment (Java Development Kit) that includes, among other things, the java compiler and the java archiver whereas the JRE (Java Runtime Environment) is only for running applications that have already been compiled and packaged as a jar archive. A JDK includes a JRE but the reverse is not true. The mvn command stands for maven and it will take care of downloading the required libraries (i.e. Hipparchus), install them, and launch the java compiler to compile the sources and then launch the java archiver to package them and create the orekit-10.1.jar file. For at least these two steps, maven needs a JDK.

So you should check that you installed a full JDK and that your JAVA_HOME environment variable points to its location.

1 Like

Thank you, apologies we had an intern on this and they weren’t familiar with the JAVA build process.

Yes, using the mvn package has solved the issue. Thank you Luc.