Missleading javadoc for method in Orbit class

Hi everyone,

I find the documentation of initPVCoordinate incomplete. It only states that position and velocity vectors are computed, but in fact the acceleration is also concerned. I think it is worth indicating as in case of time derivatives present, there will be an increased computational burden (due to a Jacobian matrix I believe) that seems to be non negligible in some applications, and useless if the end goal is independent of the acceleration (this brings another point: it’d be nice to have a method to clear those derivatives, or am I missing it?).
Per se it’s not dramatic that the description is missleading because the method is protected, but it can be called within the public one getPVCoordinates.


Glad to see my concern is shared by the community :joy:
My original post is actually part of a bigger problem I think: the class PVCoordinates and its cousins, whose name is completely oblivious to the fact that it also contains an acceleration vector. So why not PVACoordinates? If it’s historical reasons, can we use the upcoming major release to break this API?


I must say that I’ve also always wondered why it was not called PVACoordinates :sweat_smile:.

i would say +1 for changing this in 12.0 as it could be easily changed even for the user’s code by CTRL+R or the use of a standard IDE.

Have nice day,

The reason is historical (as I always say: you were not born when we decided that :older_man:)
At the beginning, this class included only position and velocity, acceleration was added several years later.

I agree the name is misleading.

Up to known we refrained from changing it because it is probably one of the most used type in Orekit (perhaps second or third rank, the first one being AbsoluteDate and another candidate for second being Frame). So this change is trivial but will require numerous changes in user’s code.

But you know, I am an old man now, I have to let young people express their ideas, so I am ready to accept this change, upi are all the future of Orekit ! :baby: