⚠ Gitlab forge migration on Monday February 12

:warning: :warning: :warning: :warning: :warning:

Dear all,

I’m planning to migrate the Gitlab forge next Monday (February 12). I hope to be finished within the day. Our forge won’t be accessible during the migration, and I urge you not to attempt any changes to repositories or other forge content on that day, as you could lose any changes you’ve made.

I’ll confirm the start of the operation on Monday morning and let you know when the migration is complete (or if I run into any difficulties… :frowning: ).

:warning: :warning: :warning: :warning: :warning:


good luck!

Take your hands off the keyboard, I’ll start the migration! :slight_smile:

1 Like

The Gitlab migration is taking longer than expected. It is not yet complete, as it involves some major version changes. I hope to be finished by this evening.

I apologize for this.

Good luck Sébastien and thank you!

1 Like

I’ve just discovered that in order to go from version 15.2 to 16.8, I have to complete 8 steps (i.e. go through 7 intermediate key versions before deploying 16.8). This update is going to take me all day!


Good luck :four_leaf_clover:

1 Like

:fireworks: I’ve finished migrating Gitlab. You can now use our new instance. The change of host has enabled us to update the operating system, and then Gitlab. You now have access to version 16.8.2 instead of 15.2.

The only perceptible change should be the change in the server’s SSH key, which should cause an error the next time you try to clone or update your repository:

$ cd /path/to/orekit/repo
$ git pull
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
Please contact your system administrator.
Add correct host key in /home/user/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /home/user/.ssh/known_hosts:150
  remove with:
  ssh-keygen -f '/home/user/.ssh/known_hosts' -R 'gitlab.orekit.org'
Host key for gitlab.orekit.org has changed and you have requested strict checking.
Host key verification failed.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

As requested, delete the gitlab.orekit.org server signature record from the ~/.ssh/known_hosts` file:

$ ssh-keygen -f '/home/user/.ssh/known_hosts' -R 'gitlab.orekit.org'
# Host gitlab.orekit.org found: line 150
/home/user/.ssh/known_hosts updated.
Original contents retained as /home/user/.ssh/known_hosts.old

Now, you can update your repository:

$ git pull
The authenticity of host 'gitlab.orekit.org (2001:41d0:601:2000::23ce)' can't be established.
ED25519 key fingerprint is SHA256:+RT4J/nl7T/0so0ercEcvS/WtBYecVWnUS/tgqziJ0A.
This host key is known by the following other names/addresses:
    ~/.ssh/known_hosts:189: [hashed name]
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added 'gitlab.orekit.org' (ED25519) to the list of known hosts.
remote: Enumerating objects: 12, done.
remote: Counting objects: 100% (3/3), done.
remote: Compressing objects: 100% (3/3), done.
remote: Total 12 (delta 0), reused 0 (delta 0), pack-reused 9
Unpacking objects: 100% (12/12), 12.60 KiB | 1.80 MiB/s, done.
From gitlab.orekit.org:orekit/website-2015
   7b21e18..97e588e  develop    -> origin/develop
   3b7f4d7..cb901ee  master     -> origin/master
Updating 7b21e18..97e588e

People who have enrolled their own Gitlab Runner also need to restart their instance. If you or your runner still can’t access Gitlab, it may be that the security tools have banned your IP address. In this case, please contact me to speed up the process.

1 Like

Great job Sébastien!
Everything worked as you explained.

1 Like

Thank you very much Sébastien!

1 Like